概要説明
突然WordPressが更新できなくなったので調査。エックスサーバーで設定されているリクエスト数の上限設定の影響で更新ができないようだったのでphp.iniのmax_input_varsの上限値を変更することで解決できました。
~ 目次 ~
原因は max_input_vars の上限値に達していたため ( 入力項目数が多い )
突然アイキャッチもテキストも保存できない状態になってしまいました。下記の対応で解決できているので保存をしてもエラーも表示されずなぜか編集データが保存されないという方はお試しください。
データを送信するリクエスト数が上限値になっていたことが原因。
エックスサーバーの場合は管理画面からphp.iniの変更が可能
管理画面の「php.ini設定画面」にはmax_input_varsの項目が無いため「直接編集画面」にて追記
php.ini
max_input_vars = 10000
上記設定を追加することでWordPressの更新は問題なく行えるようになりました
カスタムフィールドやElementorを使っている場合は要注意
編集画面の入力項目数が多くなりやすい環境のため更新できなくなったらphp.iniの設定を見直してみましょう


